Routing RIP V 1 pada Cisco IOS

Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN (Local Area Network) dan WAN (Wide Area Network). Oleh karena itu protokol ini diklasifikasikan sebagai Interior Gateway Protocol (IGP). Protokol ini menggunakan algoritma Distance-Vector Routing. Pertama kali didefinisikan dalam RFC 1058 (1988). Protokol ini telah dikembangkan beberapa kali, sehingga terciptalah RIP Versi 2 (RFC 2453). Kedua versi ini masih digunakan sampai sekarang, meskipun begitu secara teknis mereka telah dianggap usang oleh teknik-teknik yang lebih maju, seperti Open Shortest Path First (OSPF) dan protokol OSI IS-IS. RIP juga telah diadaptasi untuk digunakan dalam jaringan IPv6, yang dikenal sebagai standar RIPng (RIP Next Generation / RIP generasi berikutnya), yang diterbitkan dalam RFC 2080 (1997) (Wikipedia.org)

Karena hari ini  praktikum jaringan dengan judul RIP V 1 di cisco simulator pada laboratorium jaringan polinela, saya mengenalkan metode routing dinamis kepada mahasiswa manajemen informartika

Contoh sederhana yang saya lakukan pada router 11 adalah sebagai berikut :

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#route rip

Router(config-router)#network 192.168.2.0

Router(config-router)#network 192.168.5.0

Router(config-router)#network 192.168.6.0

Router(config-router)#network 192.168.3.0

Jadi intinya setelah mengkonfigurasi ip address pada setiap interface maka lakukan perintah masukan perintah diatas, pemberian kode network berbeda beda pada setiap router tergantung dari kaki – kaki network yang terpasang pada setiap router

Berikut ini saya tuliskan hasil konfigurasi sederhana pada semua router :

Router 8:


Router#show running-config

Building configuration...

Current configuration : 438 bytes

!

version 12.4

no service password-encryption

!

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.4.2 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

network 192.168.1.0

network 192.168.4.0

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

End

Router 9:

</pre>
Router#show running-config
Building configuration...
Current configuration : 438 bytes
!
version 12.4
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router rip

network 192.168.1.0

network 192.168.2.0

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end
<pre>

Router 10 :

</pre>
Router#show running-config

Building configuration...

Current configuration : 924 bytes

!

version 12.4

no service password-encryption

!

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 192.168.3.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.4.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

!

interface Serial0/0/1

no ip address

!

interface Ethernet0/1/0

no ip address

duplex auto

speed auto

!

router rip

network 192.168.3.0

network 192.168.4.0

network 192.168.70.0

network 192.168.71.0

network 192.168.72.0

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

Router#
<pre>

Router 11 :

</pre>
Router#show running-config

Building configuration...

Current configuration : 688 bytes

!

version 12.4

no service password-encryption

!

hostname Router

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.3.1 255.255.255.0

duplex auto

speed auto

!

interface Ethernet0/0/0

ip address 192.168.5.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0

ip address 192.168.6.1 255.255.255.0

clock rate 64000

!

interface Serial0/1/1

no ip address

!

interface Vlan1

no ip address

shutdown

!

router rip

network 192.168.2.0

network 192.168.3.0

network 192.168.5.0

network 192.168.6.0

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

<strong> [/sourcecode ]

router 13 :</strong>


kemiling#show running-config</pre>
Building configuration...

Current configuration : 406 bytes

!

version 12.4

no service password-encryption

!

hostname kemiling

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

ip address 192.168.5.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

router rip

network 192.168.5.0

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

kemiling#

Router 15 :

jakarta#show running-config

Building configuration...

Current configuration : 503 bytes

!

version 12.4

no service password-encryption

!

hostname jakarta

!

!

!

!

!

ip ssh version 1

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/2/0

ip address 192.168.6.2 255.255.255.0

!

interface Serial0/2/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router rip

network 192.168.6.0

!

ip classless

!

!

!

!

!

line con 0

line vty 0 4

login

!

!

end

jakarta#
<pre>

Configure IOS Cisco With Linux

For newbie in Cisco like me, tutorial like this is really needed. Before writing this post, i even don’t know how to open Cisco terminal 😀 . But after get some help from my friend, i can update the IOS by myself 😀 . In Windows, you can use HyperTerminal to help you configure Cisco Router. But how can you do that in linux?

There are 2 alternatives as far as i know. You can use minicom or cutecom as HyperTerminal alternatives. The difference between those two is minicom is text based and cutecom has a nice GUI. But no difference in their functionalities. To use this program you must know the setup configuration to run this program. Below is the main config in order to open your cisco router :

* Baud Rate : 9600
* Data Bits : 8
* Stop Bits : 1
* Parity : None
* Handshake : None (Not Hardware and Not Software)

If you use minicom for the first time,just type minicom -s to setup minicom for the first time. If you use Serial-To-USB cable, your device maybe connected to /dev/ttyUSB0. If you use cutecom, just type /dev/ttyUSB0 in the ‘device’ dropdown box. After that, use your favourite browser to open Cisco Documentation. It’s really good for beginner.